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1. PREFACE 

 
This manual will guide you through the installation and operation of the ETL uPD780973 

Programmer, referenced hereafter as the uPD78-Programmer. 
The uPD78-Programmer has been designed for Reading, Programming of EEPROM 

contents of the next NEC Microcontroller Unit (MCU): 
 

 uPD780973 
 uPD780949 
 uPD78F0949 
 uPD78F0828A M1 

Note: Devices that not mentioned above in lis t can’t be guaranteed of correct 
reading, programming by uPD78-Programmer. 

 
2. CHECKLIST AND REQUIREMENTS 

 
The supplied with the uPD78-Programmer: 

 uPD78-Programmer PC software on CD-ROM – Optional Extra

 following describes what items are 
 uPD78-Programmer – supplied 
 Cable -A DB9 “straight-thru” cable - supplied 

 

T C
munication Port (COM1...8) 

ded 

 supply source 
 OS

 Note: Free DWG Viewer 3.0 software can be downloaded 
from http://www.etlweb.com/files/viewers/dwgviewer.zip

 
he P  system requirements : 

 Desktop PC and a free Serial Com
 Memory - Minimum 32 Mbytes 
 Display - Color SVGA display recommen
 Preinstalled DWG Viewer 3.0 software* 
 Power supply 12 Volt/500 mA linear power

 -MS-Windows (Win98, Win2000/XP) 
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3. INSTALLATION AND USE 

 
The uPD78-Programmer includes two LED’s and mode jumper (Figure 1).  
Color LED’s indicates programmer state and external power supply voltage (Table 1, 2). 

 
GREEN uPD78-Programmer is ready. 

GREEN Flashing uPD78-Programmer is busy. 
DARK Voltage applied to uPD78-Programmer lower than 6 Volt. 

Table 1. LED D2 color meaning 
 
 

GREEN All signals on In-Circuit Programmer connector are active. 
DARK Signals on In-Circuit Programmer connector are deactivated (in three state). 

Table 2. LED D3 color meaning 
 

Jumper-1 (JP1) is intended for uPD78-Programmer mode selection (see Table 3). 
 

JP1 Shorted Normal operation. NEC device EEPROM Reading/Programming. 

JP1 Opened Service mode. uPD78-Programmer firmware update. 

Table 3. uPD78-Programmer operation modes 
 
 

In-Circuit
Programming
Connector

External
Power Supply
Connector (9-12V)

P
C

 S
er

ia
l P

or
t

C
on

ne
ct

or

Programmer
Operation mode
LED (D2)

Firmware
Update
Jumper JP1

In-Circuit
Bus activity
LED (D3)

 
Figure 1. The uPD78-Programmer board layout 
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3.1 PROGRAMMER CHECK AND CONNECTION TO PC 

 
 Connect the power supply source to uPD78-Programmer (an external 12 V DC power 

supply source is required). 
 Attach a COM port cable to the 9-pin connector on the programmer and to a COM port 

on the PC. 
 Insert jumper JP1 (see Figure 1). 
 Turn On power supply source and make sure that LED D1 appear green. 
 Start uPD78-Programmer software. 
 After few seconds you should see on display message: “uPD780973 Programmer Ver-

X.X detected”. 
 In case when you should see message: “uPD780973 Programmer Ver-X.X not found”, 

change COM port number. To do that select “Tools” menu item and than select “Comm 
Port Options”. Select new COM port number. After pressing “OK” button the new 
setting will be applied and software reattempts connection with programmer. 

 Now uPD78-Programmer ready to operate. 
 

 Note: Update uPD78-Programmer firmware if required (see Section 3.2). 
 

3.2 PROGRAMMER FIRMWARE UPDATE 
 

Thi  firmware (ATMEGA 16) of uPD78-Programmer. 

at LED D1 appears green. 

 3 Programmer Ver-X.X detected” and version 

date firmware. 

 ware update completed, turn off power supply, close uPD78-Programmer 

 . New firmware version “uPD780973 
Programmer Ver-X.X detected” will appear. 

s section describes how to update
 Remove JP1 (see Figure 1). 
 Turn On power supply; make sure th
 Start uPD78-Programmer software. 

Compare firmware version “uPD78097
specified in “Help>About” menu item. 

 If versions not coincide, follow next steps to up
 Select menu item “Tools>Firmware Update”. 
 After message box “Firmware Update” appeared, press “OK” button. 

After firm
software. 

 Insert JP1. 
 Turn On power supply. Make sure that LED1 appear green. 

Start uPD78-Programmer software on PC
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4. INTERFACE TYPES 

 
This section describes In-Circuit Programming (ICP) interface, of uPD78-Programmer. 
 

4.1 IN-CIRCUIT PROGRAMMING 
 

In-Circuit programming interface is basic for uPD78-Programmer. With this interface uPD78-
Programmer automatically detects target MCU bus speed. Ceramic resonator connected to NEC 
MCU must be in range from 4 MHz to 8.372 MHz. Signals required for communication with target 
MCU described in Table 3. 
 

PIN number Programmer Signal Description 
1 Communication Pin1 
2 Communication Pin2 
3 Communication Pin3 
4 Communication Pin4 
5 Communication Pin5 
6 Communication Pin6 
7 Communication Pin7 
8 Communication Pin8 
9 IC Pin(Factory test mode) 
10 Reset Pin 
11 Communication Pin9 
12 Communication Pin10 
13 Built-in power supply +5V (Vcc). 
14 Signal Ground (Vdd) 

 
Table 3. Pin functions of uPD78-Programmer ICP connector 
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5. WORKING WITH TARGET MCU 
 
This section contains overall information about NEC78 MCUs supported by uPD78-

Programmer. When uPD78-Programmer successfully installed (see Section 3) target devices can 
be read, program and verify. 
 

5.1 In-Circuit EEPROM reading example 
 

 Connect required pins to board with target MCU (see Appendix). 
 Apply power to uPD78-Programmer. LED D2 became to green light (see Table 1). 
 Select corresponding device in uPD78-Programmer software (“Device” button). 
 Select “Read Sequence” panel in uPD78-Programmer software. 
 Press “EEPROM” button. 
 Press “Start” button. 
 LED D3 on uPD78-Programmer became to green light. That means that +5 voltage 

regulator switched on and VCC applied to target MCU. 
 Now uPD78-Programmer automatically detects MCU bus speed. 
 When LED D2 on uPD78-Programmer became permanent green, reading completed. 

Target MCU powered off. 
 After read sequence successfully completed it is necessarily to save memory dump to 

file (see Section 6.2). 
 If some errors appeared during reading process refer to Section 7. 

 
5.2 In-Circuit EEPROM programming example 

 
 Connect required pins to board with target MCU (see Appendix). 
 Apply power to uPD78-Programmer. LED D2 became to green light (see Table 1). 
 Select corresponding device in uPD78-Programmer software (“Device” Button). 
 Load EEPROM data from file (see Section 6.1) or enter data to Hex Editor. 
 Select “Program Sequence” panel in uPD78-Programmer software. 
 Press “EEPROM” button. 
 Press “Start” button. 
 LED D3 on uPD78-Programmer became to green light. That means that +5 voltage 

regulator switched on and VCC applied to target MCU. 
 Now uPD78-Programmer automatically detects MCU bus speed. 
 When LED D2 on uPD78-Programmer became permanent green, programming 

completed. Target MCU powered off. 
 If some errors appeared during programming process refer to Section 7. 

Note: Strongly recommended before EEPR OM programming, for a first time, 
read EEPROM contents and save it to file. 
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6. FILE OPERATIONS 
This section describes basic rules working with files. Memory dump from Hex Editor (Buffer) 

can be load/save from/to hard disk. Also short descriptions such as project name, MCU type and 
memory cell assignment can be done for future fast remind. uPD78-Programmer accepts tree types 
of file formats:  

 BIN (Binary format) 
 Motorola S-Record (4 byte address) 
 Motorola S-Record (6 byte address) 
 EEF (Extended ETL Format) 

 
6.1 LOAD FILE INTO BUFFER 

 
 Select “File>Open” menu item. 
 Press “Browse” button. 
 In File Open Dialog window, select file witch need to be open.  
 Press “Open” button. 
 Than opposite “Auto Format Detected:” text, select correct file format. Note that software 

try automatically detects file format, but unknown records in file will fail this detection. 
“Load Entire file” check box must be checked if automatically loading procedures 
required. 

 Than press “OK” button. 
Sometimes load data from file to specific buffer allocations required. For Example if required 

load buffer from $F900 address from binary file beginning from $0000 address follow next steps: 
 Select “File>Open” menu item. 
 Press “Browse” button. 
 In File Open Dialog window, select file which need to be open. 
 Press “Open” button. 
 Than, opposite “Auto Format Detected:” select Binary format. 
 Uncheck “Load Entire File” check box. 
 In field “Offset Value to Place Data to Buffer:” enter 0xF900. 
 Than press “OK” button. 
 Now data placed to Hex Editor Buffer from the beginning of 0x0400 address. 

If more complicated operations with files required, for example load Hex Editor Buffer from 
many files “Lowest Address From File To Load”, “Highest Address From File To Load” and 
“Clear Buffer Before Loading File” options are available. 

 
6.2 SAVE FILE FROM BUFFER 

 
 Select “File>Save” menu item. 
 Press “Browse” button. 
 Select directory in which file will be saved. 
 Type file name, for example “test1” 
 Press “Save” button. 
 Than select format in which file will be saved*. 
 Press “OK” button. 

Note: Use EEF Format for future “Load File Into Buffer” automatically 
processing. Also, only in EEF Format

 
 Project Description, Device Name and 

Memory Cells attributes can be saved. 
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7. ERRORS AND TROUBLESHOOTING 
 
This section describes most recently encountered problems, errors and fixing solutions. 
 

 Problem: LED D1 (see Figure 1) Dark. 
 Causes: This problem can accrue when external power supply connected to uPD78-

Programmer is damaged or connected in wrong polarity. 
 Solutions: Check voltage on uPD78-Programmer power clamps. It must be 9-12 V. 

 
 

 Error Message: uPD780973 Programmer not found. 
 Causes: This message can appear when uPD78-Programmer software couldn’t 

establish connection with uPD78-Programmer board. 
 Solutions: Check connection of COM port cable from PC to uPD78-Programmer 

board. Apply power from external power supply to uPD78-Programmer. In 
menu item “Tools>Comm Port Options” select correct COM port number. 

 
 

 Error Message: Communication Error. 
 Causes: This message can appear when Communication between uPD78-

Programmer and PC is broken. 
 Solutions: Check COM port cable connection to board and PC. If message not 

disappear restart the computer. 
 
 

 Error Message: IC Pin must be in 'high' state (line 9). 
 Causes: This message can appear when MCU IC pin connected to ground through 

external components. 
 Solutions: Cut any component from IC pin. 

 
 

 Error Message: Reset Pin must be in 'high' state (line 10). 
 Causes: This message can appear when MCU Reset pin connected to ground through 

external components. 
 Solutions: Cut any component from Reset pin. 

 
 

 Error Message: External Reset Occurred. Disconnect Reset pin (line 10) from external 
circuit. 

 Causes: This message can appear when in time on reading/programming reset pulse 
appeared on MCU Reset pin from external circuit. 

 Solutions: Cut any component and traces from Reset pin. 
 
 

 Error Message: Parallel Communication Lines (1-8) Setup Error. 
 Causes: This message can appear when communication lines 1-8 (see Table 3) pin 

connected to ground or Vcc through external components. 
 Solutions: Cut any component from pins. 
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 Error Message: Pin Tester Errors. 
 Causes: This message can appear when NEC MCU pin(s) connected to ground or 

Vcc through external components. 
 Solutions: Cut any component from pin. To find out what pin must to be disconnected 

refer to Table 3 and Appendix. 
 
 
 

 Error Message: Echo Error. 
 Causes: This message can appear when programmer communication line 11 

connected to ground or Vcc through external components. Or ceramic 
resonator on NEC MCU has frequency instability. 

 Solutions: Cut any component from pin. To find out what pin must to be disconnected 
refer to Table 3 and Appendix. Or replace ceramic resonator connected to 
NEC MCU. 

 
 

 Error Message: No Echo From Device. 
 Causes: This message can appear when programmer lines connected in wrong way 

with NEC MCU or wrong device selected in PC software. 
 Solutions: Check lines connected to MCU and device selected in Device dialog on PC. 

Try to reconnect by pressing "Start" Button 
 
 

 Error Message: Target Device Speed too low. 
 Causes: This message can appear when ceramic resonator frequency connected to 

NEC MCU is too low. 
 Solutions: Replace ceramic resonator with frequency from 4-8 MHz. 

 
 

 Error Message: Readout time-out Error. 
 Causes: This message can appear when NEC MCU do not respond long time. 
 Solutions: Check lines connected to MCU and try to reconnect by pressing "Start" 

Button 
 
 

 Error Message: Transmitter time-out Error. 
 Causes: This message can appear when NEC MCU do not respond long time. 
 Solutions: Check lines connected to MCU and try to reconnect by pressing "Start" 

Button 
 
 

 Error Message: Programming time-out Error. 
 Causes: This message can appear when NEC MCU do not respond long time. 
 Solutions: Check lines connected to MCU and try to reconnect by pressing "Start" 

Button 
 
 

 Error Message: Programming Error. 
 Causes: This message can appear when programming of EEPROM completed with 

errors. 
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 Solutions: Try to repeat programming sequence. If error still exists replace ceramic 
resonator to 8MHz frequency. 

 
 

 Error Message: External Power Supply Error, Current Protection. 
 Causes: This message can appear when current consumption from built-in power 

supply grater than 250 mA. 
 Solutions: Check target MCU power pins on short circuit. 

 
 

 Error Message: WRONG SUBROUTINE CALL 
WRONG DEVICE TYPE 

 Causes: These messages can appear when fatal problems with UPD78-Programmer 
hardware/firmware accrued. 

 Solutions: Contact ETL technical support. 

Note: uPD78-Programmer has Log Window which can be stored to file. To 
perform this operation right clicks on Log Window. Than click on “Save
uPD78prog.log file“ menu item. Now this file can be found in the same 
directory as UPD78-Programmer software. Log File can be se

 
 to 

nd by E-mail to 
techsupport@etlweb.net for non described problem solution. 

 

form to applicable. Report any defects for a 45 
days period, from the applicable data on invoice. 

 
 

ETL warrants that Product delivered shall con

8. WARRANTY STATEMENT 
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Figure 2. In-Circuit wiring diagram for uPD780973 MCU 

Note: In RED color denote d lines from UPD78-Programmer that must be 
connected to target MCU. 

9. APPENDIX 
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Figure 3. In-Circuit wiring diagram for uPD78(F)0948/49 MCU 

Note: In RED color denote d lines from UPD78-Programmer that must be 
connected to target MCU. 
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Figure 4. In-Circuit wiring diagram for uPD78(F)0828A MCU 

Note: In RED color denote d lines from UPD78-Programmer that must be 
connected to target MCU. 
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